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FAQ: Importing GIS Files into MobileMapper Office 
11 June 2007 
 
What GIS files can I import into MobileMapper Office? 
MobileMapper Office supports importing GIS files in Autodesk’s DXF, ESRI’s SHP and 
MapInfo’s MIF formats. 
 
Exactly which file types does MobileMapper Office import? 
1. When you select the DXF import option, the program imports the selected DXF file. 
2. When you select the MIF import option, both MIF and MID files for the specified 

GIS file are imported into the MobileMapper job.  
3. When you select the “SHP” option, MobileMapper Office imports into a 

MobileMapper job file (MMJ) all the information included in all the following files 
that comprise a shapefile: SHP, SHX, and DBF files. MobileMapper Office does not 
read the fourth type of file making up some shapefiles (with the PRJ extension) 
because these are written in a format that is proprietary to ESRI. If ESRI “opens” this 
file type to the public, as they have done with SHP, SHX and DBF files, Magellan 
will be able to support them with MobileMapper Office. Exporting PRJ files will save 
you from manually modifying some settings, such as the coordinate system and 
drawing attributes in your ESRI GIS software. 

 
What are the basic steps I should follow to import jobs in GIS 
format? 

1. Open a job in MobileMapper Office 
Turning on MobileMapper Office automatically opens an empty, “untitled” job. As 
with Microsoft Office applications, you may name this job using the File > Save As 
function or you may open an existing job using the File > Open function. You may 
also open a MobileMapper job clicking on File and selecting one of the jobs listed at 
the bottom on the window that you have recently opened. 

2. Click on File > Import 
This will bring up a browsing window that will allow you to do 3 things: 

- Select the “files of type”(select the extension of the files you want to import) 
- Select the directory in which to search for files to import 
- Select the name of the file you want to import by clicking on it 

3. When you have selected the file you want to import, click on “open” 
in the lower right of the browsing window.  
This action brings up a window displaying some information on the selected file and 
requiring some actions on your part. First, there is a box at the top of the window in 
which you MUST select the coordinate system of the file you are importing. The 
address of the file is also listed, including the file name. To the left of the file name is 
the symbol that will be used to display the file in MobileMapper Office. All the layers 
contained in the file are then listed. 
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4. Select the coordinate system of the file you wish to import 
You must know what coordinate system was used for the GIS file you wish to import. 
If you are unsure of the coordinate system, you should ask someone in your mapping 
or GIS department what the coordinate system is. Many departments use only one 
coordinate system/datum for the majority of their files and so you may only have to 
ask this question once. The default coordinate system is “Geodetic” (latitude-
longitude) and the default datum is WGS84. Many maps are in a grid coordinate 
system such as Universal Transverse Mercator (UTM) or US state plane coordinates. 
Many countries use their own grid systems. MobileMapper Office supports many of 
these systems.  
 
Select the coordinate system by clicking on the small square button in the upper right 
of the Import GIS Data window that has three dots on it. This opens the Select 
Coordinate System window. Again click the button with the three dots and select the 
system you want to use. If you do not see it, click New. On the Coordinate System 
Wizard’s Welcome screen, select “Select a Pre-Defined System” and click Next. 
Then browse for the system you wish to use. If you do not see it, you should return to 
the Welcome screen, and select one of the options for creating a coordinate system. 
Once you select or create a system, it is listed on the Select Coordinate System dialog 
box. 
 
If you select “Geodetic” as the System Type, click on the down arrow next to the 
Geodetic Datum box to select one of the supported datums. If you cannot find the 
datum you want, you can create a new one by selecting “NEW” at the top of the list 
of datums. Then click the button with three dots that is to the right of the Geodetic 
Datum box. This will display a window where you can name your datum and enter 
the transformation parameters and ellipsoid from a list. If you cannot find the 
ellipsoid you wish to use, click on the button with three dots and enter the parameters 
for the desired ellipsoid: name, semi-major axis and inverse flattening parameter. 
 
If you select “Grid” as the System Type, click on the down arrow next to the Grid 
System box to select one of the supported grids. If you cannot find the grid system 
you want, you can create a new one by selecting “NEW” at the top of the list of grids. 
Then click on the button with three dots that is to the right of the Grid System box. 
This will display a Grid System Definition window where you name the new grid, 
click on the button with three dots and fill in the Zone Definition Dialog box.  
 
A Special Note on ESRI products and Lambert Conformal Conic Projections 
MobileMapper Office supports three types of Lambert Conformal Conic projections. 
They are described as "Lambert_Conformal_Conic_1SP," 
"Lambert_Conformal_Conic_2SP” and "Lambert_Conformal_Conic_27.”  When you 
import a GIS file in a US state plane coordinate system into a MobileMapper job or 
background map, you must select one of these definitions of the Lambert Conformal 
Conic projection. Some ESRI products, e.g., ArcMap 8.0, generate PRJ files that list 
the projection for NAD83 state plane coordinate systems as 
"Lambert_Conformal_Conic." However, all state plane coordinate systems using the 
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NAD83 datum use the “Lambert_Conformal_Conic_2SP” projection. So when you 
import a shapefile in an NAD83 state plane system, you should first edit the PRJ file 
by changing “Lambert_Conformal_Conic” to “Lambert_Conformal_Conic_2SP.” 
After exporting a MobileMapper job file to shapefile format, you should check other 
PRJ files used by your GIS to see if you need to delete the “2SP” string from the 
projection definition. 

5. (Optional) Select an attribute to display as a label on the map 
screen 
If you want to select a particular attribute of a layer to display as a label on 
MobileMapper Office’s map screen, right click on the desired attribute and click on 
"Set as Feature Name."  The attribute name will be displayed in bold face and there 
will be a key icon next to it. If the layer displays highways and one of the attributes is 
“Route Number,” if you set this attribute as the feature name, all the highways in the 
file will be labeled with their route number. 

6. (Optional) Import attribute values as menu-style attribute values 
Numeric-style attributes contained in ESRI .dbf and MapInfo .mid files will imported 
automatically into MobileMapper Office as numeric-style attributes.  Text-style and 
menu-style attributes will be imported by default as text-style attributes into 
MobileMapper Office.  If you wish to import a shapefile’s or MIF file’s attributes 
into MobileMapper Office as menu-style attributes, right-click on the attribute in the 
Import GIS Data window and select the Menu option. 

 
 
All the text strings previously recorded as attributes in the imported file will be 
written as menu items in the resultant MobileMapper feature library. If you upload 
this file into the MobileMapper Pro receiver, you will be able to select an attribute 
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from this list – which is faster than using the receiver’s “soft” keypad to type out a 
comment or description. 
In the above example, the "ID" attribute is already a numeric style attribute and so 
will remain a numeric-style attribute in the MMF. You will be able to use 
MobileMapper Office’s Feature Library Editor to edit the number of significant digits 
to the right of the decimal point, the default value and the maximum/minimum values 
permitted. 
If you turn what had been a text-style attribute in the GIS into a menu-style attribute 
in MobileMapper Office and wish to undo this action, you can re-importing the GIS 
file and overwrite the first MMJ file you created. However, it is often easier to open 
the MMJ file with MobileMapper Office, click Tools > Feature Library Editor, 
delete the attribute, and create a new text-style attribute with the same name. 

7. (Optional) Select the map symbol or drawing attribute to display on 
the map screen 
The name of the layer appears at the top of the attribute list. Next to it is the symbol 
(point features) or drawing attributes (line and area features) that will be used to 
display the layer on the MobileMapper map screen. To change this symbol or 
drawing attribute, double-click on the name and make your selection. Remember to 
choose a color for line and area features that will allow you to see these features on 
the map display. 

8. Click the Import button 
When you have selected the proper coordinate system and the map symbols you want 
to display, click on the Import button at the bottom of the Import GIS Data 
window. 

  
What is the most common cause of problems when importing 
GIS files into MobileMapper jobs?  
When you import GIS files, you have to identify the coordinate system and datum used to 
display the GIS file. When importing a shapefile that includes a PRJ file, MobileMapper 
Office will automatically read the PRJ file and automatically set the proper coordinate 
system. If you are importing shapefiles without a PRJ file, DXF files or MIF files, you 
can determine what system was used, by displaying the file in your GIS or by asking the 
GIS manager. You typically have to ask this question only once because most GIS files in 
a project are in the same coordinate system. Some organizations use the same coordinate 
system for all of their files. 
 
How do I import multiple GIS files that are in different 
coordinate systems? 
You should first determine the coordinate system of each GIS. Set MobileMapper Offices 
coordinate system to that of the first file and import it. Then set MobileMapper Office to 
the second GIS file’s coordinate system and import the second file, etc. 
To set the coordinate system in MobileMapper Office, click on Options > Select 
Coordinate System, scroll down to “New” on the Select Coordinate System dialog box. 
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On the Coordinate System Wizard’s Welcome screen, select “Select a Pre-Defined 
System” and click Next. Then browse for the system you wish to use. If you do not see it, 
you should return to the Welcome screen, and select one of the options for creating a 
coordinate system. Once you select or create a system, it is listed on the Select 
Coordinate System dialog box. 
 
When I import SHP files, I notice that there are other files with 
the same name as the SHP file but with different file 
extensions. What are these? 
ESRI’s shapefiles can comprise four different types of files: SHP, SHX, DBF and PRJ 
files. Files with the SHP extension contain information on feature geometry and 
geographic position. SHX files link feature geometries and positions with feature and 
attribute information that is contained in DBF files. PRJ files contain some additional 
information such as the coordinate system and datum being used and drawing attributes 
such as fonts, map symbols, etc. There is a separate FAQ on importing file that provides 
more information on this subject. 
 
When I import MIF files, I notice that there another file with 
the same name as the MIF file but with an MID file extension. 
What is this? 
MapInfo files comprise two different types of files: MIF and MID files. Files with the 
MIF extension contain information on feature geometry and geographic position. MID 
files contain the feature and attribute information. There is a separate FAQ on importing 
file that provides more information on this subject. 
 
Can I import features of different geometries in a single MIF 
file into MobileMapper Office? 
Yes. However, you may wish to convert such a MIF file into shapefile format. This will 
separate the various themes into separate files. You may then import only those themes 
you want into MobileMapper Office. 
 
Is it possible to select an attribute of a feature to be displayed 
on the map screen?  For example I have loaded a shapefile with 
roads and I want to display the name of the road rather than 
its route number.   
To display a particular attribute type for a layer imported into a MobileMapper job or 
background map, you should right click on the attribute you wish to display and click 
“Set as Feature Label.” It is important that you do this as you are importing data. Once 
the data is imported into a job, MobileMapper Office automatically creates a feature 
library and you cannot edit a job feature library except as a standalone library to be used 
with other jobs..  
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I tried to import a feature library into another one and got an 
error message saying “Import Failed.”  What does this mean 
and how can I avoid it? 
When using the Feature Library Editor's Import function, if you select a file containing 
more than 20 characters (excluding dot and extension symbols) in the name, the software 
will truncate all characters beyond the 20th. If the first 20 characters in two imported files 
are identical, the software displays a message saying the file already exists and generates 
"Import Failed" error. You should rename the second file so that its first 20 characters are 
not identical to any previously imported file. 


